summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorRafal Somla <rafal.somla@oracle.com>2011-11-17 12:34:52 +0100
committerRafal Somla <rafal.somla@oracle.com>2011-11-17 12:34:52 +0100
commitaa21a7105907bba171a515b80705dffbe857baeb (patch)
treeab85dad85e5b89827c6f4311eb4de16bf2087ca2 /sql/CMakeLists.txt
parentc06225f700c7cf52592a4750f3514f8302e54dc9 (diff)
downloadmariadb-git-aa21a7105907bba171a515b80705dffbe857baeb.tar.gz
Bug#13101974 SLAVE CAN'T CONNECT AS REPLICATION USER USING WINDOWS AUTH PLUGIN
Problem was that built-in client-side support for Windows Native Authentication (WNA) was included only in the client library, but not into the server code (which also uses some of the sources from the client library). This is fixed by modyfying sql/CMakeLists.txt to include the client-side WNA plugin library and enable WNA related code by defining AUTHENTICATION_WIN macro. Also, the logic of libmysql/CMakeLists.txt is simplified a bit.
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index fb86d1ce60f..2e02e67c2c9 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -90,7 +90,14 @@ TARGET_LINK_LIBRARIES(sql ${MYSQLD_STATIC_PLUGIN_LIBS}
${LIBWRAP} ${LIBCRYPT} ${LIBDL}
${SSL_LIBRARIES})
-
+#
+# On Windows platform we compile in the clinet-side Windows Native Authentication
+# plugin which is used by the client connection code included in the server.
+#
+IF(WIN32)
+ ADD_DEFINITIONS(-DAUTHENTICATION_WIN)
+ TARGET_LINK_LIBRARIES(sql auth_win_client)
+ENDIF()
IF(WIN32)
SET(MYSQLD_SOURCE main.cc nt_servc.cc nt_servc.h message.rc)