summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2011-02-21 20:17:26 +0100
committerVladislav Vaintroub <wlad@montyprogram.com>2011-02-21 20:17:26 +0100
commitab136fc6be8c8a19fe7ca0b99bde7050c37b4153 (patch)
tree7c077b0ef69d5ca03a0326dacc5958ddcf532349 /sql/CMakeLists.txt
parent04879e4045e939b7a032b77578c6db92100e7b02 (diff)
downloadmariadb-git-ab136fc6be8c8a19fe7ca0b99bde7050c37b4153.tar.gz
Bug#53240 :Fixed dependency to prevent occasional situations
where bison runs in parallel with the same input and output files
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index f81afa6b27b..c997846a4c6 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -149,8 +149,7 @@ ADD_CUSTOM_TARGET(
${PROJECT_SOURCE_DIR}/sql/message.rc
${PROJECT_SOURCE_DIR}/sql/lex_hash.h)
-ADD_DEPENDENCIES(mysqld GenServerSource)
-
+ADD_DEPENDENCIES(sql GenServerSource)
# Remove the auto-generated files as part of 'Clean Solution'
SET_DIRECTORY_PROPERTIES(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES
"lex_hash.h;sql_yacc.h;sql_yacc.cc;mysqld.def")