summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <georg@lmy002.wdf.sap.corp>2006-09-21 15:19:20 +0200
committerunknown <georg@lmy002.wdf.sap.corp>2006-09-21 15:19:20 +0200
commit10bec20ee3d4490d0041d0ed83d5239ffd853f0a (patch)
treea5aad60a7e8110b50e85111760c3b454af90470a /sql/CMakeLists.txt
parentee5ffff9e7c24fc1a9df9466454d98d90fb32a24 (diff)
downloadmariadb-git-10bec20ee3d4490d0041d0ed83d5239ffd853f0a.tar.gz
Windows 64bit fixes
Fixed udf_example, so tests now can also run udf on win. sql/udf_example.def: BitKeeper file /home/georg/work/mysql/prod/mysql-5.1-win/sql/udf_example.def include/config-win.h: removed USE_32_BIT_TIME include/my_time.h: Fixed size of my_time for Win64 (should be 64bit) mysql-test/mysql-test-run.pl: Added windows paths for udf_example sql/CMakeLists.txt: Added udf_example.dll sql/udf_example.c: Windows doesn't know about socket.h and friends. Use winsock.h instead
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 8d97edd4652..d9031e0982f 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -117,3 +117,7 @@ ADD_CUSTOM_COMMAND(
)
ADD_DEPENDENCIES(mysqld gen_lex_hash)
+
+ADD_LIBRARY(udf_example MODULE udf_example.c udf_example.def)
+ADD_DEPENDENCIES(udf_example strings)
+TARGET_LINK_LIBRARIES(udf_example wsock32)