summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@mariadb.com>2021-11-11 02:44:37 +0100
committerVladislav Vaintroub <wlad@mariadb.com>2021-11-18 17:25:40 +0100
commit68b16d80c950db507b63fb5b5a5d6552ab8a1f61 (patch)
tree767deaac4c2aba81f46b70a2a48f4fb3ae226a34 /sql/CMakeLists.txt
parent012d3cecb861268937fa05d5dfa2940f80fc235b (diff)
downloadmariadb-git-68b16d80c950db507b63fb5b5a5d6552ab8a1f61.tar.gz
MDEV-26713 Windows- UTF8 encoding in the installer
- allow utf8 datadir, and password - mysql_install_db.exe does not send clear password to mysqld --bootstrap subprocess anymore, but hash, as server makes incorrect assumption about character encoding in case it is UTF8. - use CreateServiceW to create service, due to some Windows bug, the ANSI version does not currently work well with strings outside of ASCII range.
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 972cc0b736c..848495190b2 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -481,10 +481,11 @@ IF(WIN32)
MYSQL_ADD_EXECUTABLE(mariadb-install-db
mysql_install_db.cc
${CMAKE_CURRENT_BINARY_DIR}/mysql_bootstrap_sql.c
+ password.c
COMPONENT Server
)
SET_TARGET_PROPERTIES(mariadb-install-db PROPERTIES COMPILE_FLAGS -DINSTALL_PLUGINDIR=${INSTALL_PLUGINDIR})
- TARGET_LINK_LIBRARIES(mariadb-install-db mysys shlwapi)
+ TARGET_LINK_LIBRARIES(mariadb-install-db mysys mysys_ssl shlwapi)
ADD_LIBRARY(winservice STATIC winservice.c)
TARGET_LINK_LIBRARIES(winservice shell32)