summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Botchkov <holyfoot@askmonty.org>2012-03-24 11:24:20 +0100
committerAlexey Botchkov <holyfoot@askmonty.org>2012-03-24 11:24:20 +0100
commit5c01f1ac1498a9b32bdccb817cdbc0b3ca3687d6 (patch)
treefe8eb54f1eaff9a41fe617b35356f5bd3e35746b /sql/CMakeLists.txt
parent619f67b1b4694add244377a0cb2507a035ebd306 (diff)
downloadmariadb-git-5c01f1ac1498a9b32bdccb817cdbc0b3ca3687d6.tar.gz
MDEV-15 Log all sql errors.
modified for MySQL 5.5. Logger service moved to the plugin/sql_errlog directory to be properly used later. plugin/sql_errlog/sql_errlog.c: Fixes for bugs #956427 (SQL_ERROR_LOG plugin produces bogus warnings about sql-error-log-size-limit value) and #956463 (Server crashes if SQL_ERROR_LOG fails to initialize) they're also MDEV-184 and MDEV-183 The sql_error_log_deinit() should be prepared for the logger_file to be NULL. The logger_file_size_limit upper limit wasn't properly set.
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 22c51f3ce23..446db5d128a 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -85,7 +85,6 @@ SET (SQL_SOURCE
gcalc_slicescan.cc gcalc_tools.cc
threadpool_common.cc
../sql-common/mysql_async.c
- sql_logger.cc
${GEN_SOURCES}
${MYSYS_LIBWRAP_SOURCE}
)