summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <acurtis/antony@xiphis.org/ltantony.xiphis.org>2006-08-24 22:10:55 -0700
committerunknown <acurtis/antony@xiphis.org/ltantony.xiphis.org>2006-08-24 22:10:55 -0700
commitcf9d738b6214afe33389798bd196b0205f09b3b8 (patch)
tree10cf85c6fccc323cd58e0e82f80dbaf9a8ba5542 /sql/CMakeLists.txt
parent4ec86b1c0453c18092a9f66292b19afbceadd9dc (diff)
downloadmariadb-git-cf9d738b6214afe33389798bd196b0205f09b3b8.tar.gz
fix for windows build
CMakeLists.txt: add for federated libmysqld/CMakeLists.txt: ha_heap.cc and ha_myisam.cc are removed add for federated sql/CMakeLists.txt: add for federated sql/handler.cc: fix for fussy compilers storage/heap/CMakeLists.txt: add ha_heap.cc storage/myisammrg/CMakeLists.txt: add ha_myisammrg.cc
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 7550a7af622..132362c43d1 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -75,6 +75,9 @@ ENDIF(WITH_CSV_STORAGE_ENGINE)
IF(WITH_EXAMPLE_STORAGE_ENGINE)
TARGET_LINK_LIBRARIES(mysqld example)
ENDIF(WITH_EXAMPLE_STORAGE_ENGINE)
+IF(WITH_FEDERATED_STORAGE_ENGINE)
+ TARGET_LINK_LIBRARIES(mysqld federated)
+ENDIF(WITH_FEDERATED_STORAGE_ENGINE)
IF(WITH_INNOBASE_STORAGE_ENGINE)
TARGET_LINK_LIBRARIES(mysqld innobase)
ENDIF(WITH_INNOBASE_STORAGE_ENGINE)