summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Petrunya <psergey@askmonty.org>2013-06-17 11:59:38 +0400
committerSergey Petrunya <psergey@askmonty.org>2013-06-17 11:59:38 +0400
commit03691a77718c781469b5675c6b03d6064255debb (patch)
tree8e8b24229e7334fa766b3feb8fd6e2b21cf095a6 /sql/CMakeLists.txt
parent9718b9763deeaa41008aeca31c24548e556401cc (diff)
downloadmariadb-git-03691a77718c781469b5675c6b03d6064255debb.tar.gz
SHOW EXPLAIN UPDATE/DELETE
- Introduce "Query Plan Footprints" (abbrev. QPFs) QPF is a part of query plan that is 1. sufficient to produce EXPLAIN output, 2. can be used to produce EXPLAIN output even after its subquery/union was executed and deleted 3. is cheap to save so that we can always save query plans - This patch doesn't fully address #2, we make/save strings for a number of EXPLAIN's columns. This will be fixed.
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 63e2df46bed..638c6cbca05 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -80,6 +80,7 @@ SET (SQL_SOURCE
sql_reload.cc
# added in MariaDB:
+ opt_qpf.h opt_qpf.cc
sql_lifo_buffer.h sql_join_cache.h sql_join_cache.cc
create_options.cc multi_range_read.cc
opt_index_cond_pushdown.cc opt_subselect.cc