summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Widenius <monty@mariadb.org>2014-08-19 21:35:14 +0300
committerMichael Widenius <monty@mariadb.org>2014-08-19 21:35:14 +0300
commitbd2117d154b9cc367b708932de5d6064a339462d (patch)
tree6c0fac6d84a3f88acb40ca9e410bd7724440af86 /sql/CMakeLists.txt
parentcfa1ce81bb7992c362958bb95f41325ce2109834 (diff)
parent5569132ffebba3fd2e37964543f658ed24d8caaf (diff)
downloadmariadb-git-bd2117d154b9cc367b708932de5d6064a339462d.tar.gz
Automatic merge from 5.5
Fixed 2 failing tests by replacing result files
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt21
1 files changed, 10 insertions, 11 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index d07b2106f07..c59ae3b7846 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -32,13 +32,6 @@ SET_SOURCE_FILES_PROPERTIES(${GEN_SOURCES} PROPERTIES GENERATED 1)
ADD_DEFINITIONS(-DMYSQL_SERVER -DHAVE_EVENT_SCHEDULER)
-IF (CMAKE_SYSTEM_NAME MATCHES "Linux" OR
- CMAKE_SYSTEM_NAME MATCHES "Windows" OR
- CMAKE_SYSTEM_NAME MATCHES "SunOS" OR
- HAVE_KQUEUE)
- ADD_DEFINITIONS(-DHAVE_POOL_OF_THREADS)
-ENDIF()
-
IF(SSL_DEFINES)
ADD_DEFINITIONS(${SSL_DEFINES})
ENDIF()
@@ -105,10 +98,16 @@ SET (SQL_SOURCE
${MYSYS_LIBWRAP_SOURCE}
)
-IF(WIN32)
- SET(SQL_SOURCE ${SQL_SOURCE} threadpool_win.cc)
-ELSE()
- SET(SQL_SOURCE ${SQL_SOURCE} threadpool_unix.cc)
+IF (CMAKE_SYSTEM_NAME MATCHES "Linux" OR
+ CMAKE_SYSTEM_NAME MATCHES "Windows" OR
+ CMAKE_SYSTEM_NAME MATCHES "SunOS" OR
+ HAVE_KQUEUE)
+ ADD_DEFINITIONS(-DHAVE_POOL_OF_THREADS)
+ IF(WIN32)
+ SET(SQL_SOURCE ${SQL_SOURCE} threadpool_win.cc)
+ ELSE()
+ SET(SQL_SOURCE ${SQL_SOURCE} threadpool_unix.cc)
+ ENDIF()
ENDIF()
MYSQL_ADD_PLUGIN(partition ha_partition.cc STORAGE_ENGINE DEFAULT STATIC_ONLY