summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Didriksen <tor.didriksen@oracle.com>2012-05-29 10:54:57 +0200
committerTor Didriksen <tor.didriksen@oracle.com>2012-05-29 10:54:57 +0200
commit31a93ea75d00b54326e7f1975dccafdad4e35c5e (patch)
tree5527d306e0535d86d4f429a6fa948495ee83c64d /sql/CMakeLists.txt
parent484a79415b7624cd1abb7461cb353925a0c075b7 (diff)
downloadmariadb-git-31a93ea75d00b54326e7f1975dccafdad4e35c5e.tar.gz
Bug#12845091 .EMPTY FILE IN /DATA/TEST PREVENTS USERS FROM DROPPING TEST DB ON 5.5 AND 5.6
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 09672561c11..a3df9e7948b 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -264,7 +264,10 @@ IF(INSTALL_LAYOUT STREQUAL "STANDALONE")
# We need to create empty directories (data/test) the installation.
# This does not work with current CPack due to http://www.cmake.org/Bug/view.php?id=8767
# Avoid completely empty directories and install dummy file instead.
-SET(DUMMY_FILE ${CMAKE_CURRENT_BINARY_DIR}/.empty )
+# Use a file extension so that it will be deleted in case someone does
+# 'drop database test'
+# See deletable_extentions.
+SET(DUMMY_FILE ${CMAKE_CURRENT_BINARY_DIR}/dummy.bak )
FILE(WRITE ${DUMMY_FILE} "")
INSTALL(FILES ${DUMMY_FILE} DESTINATION data/test COMPONENT DataFiles)