summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Didriksen <tor.didriksen@oracle.com>2013-02-25 10:42:40 +0100
committerTor Didriksen <tor.didriksen@oracle.com>2013-02-25 10:42:40 +0100
commit73d330b87d9d1dc9249ccdfe9562e799940b2f8c (patch)
treed1acafb0da419ddabb1983af06b255256126885b /sql/CMakeLists.txt
parent0d71d913d3808cf785d55686bdf22ff0352f02d3 (diff)
downloadmariadb-git-73d330b87d9d1dc9249ccdfe9562e799940b2f8c.tar.gz
Bug#16062056 REMOVE THE "DUMMY.BAK" FILE FROM THE TEST DATABASE, AND ADD DB.OPT
1. remove dummy.bak 2. create a db.opt file containing two lines: --- default-character-set=latin1 default-collation=latin1_swedish_ci
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt12
1 files changed, 3 insertions, 9 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index d79b732005b..d4db337d765 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -261,15 +261,9 @@ ADD_CUSTOM_TARGET(distclean
IF(INSTALL_LAYOUT STREQUAL "STANDALONE")
-# We need to create empty directories (data/test) the installation.
-# This does not work with current CPack due to http://www.cmake.org/Bug/view.php?id=8767
-# Avoid completely empty directories and install dummy file instead.
-# Use a file extension so that it will be deleted in case someone does
-# 'drop database test'
-# See deletable_extentions.
-SET(DUMMY_FILE ${CMAKE_CURRENT_BINARY_DIR}/dummy.bak )
-FILE(WRITE ${DUMMY_FILE} "")
-INSTALL(FILES ${DUMMY_FILE} DESTINATION data/test COMPONENT DataFiles)
+# Copy db.opt into data/test/
+SET(DBOPT_FILE ${CMAKE_CURRENT_SOURCE_DIR}/db.opt )
+INSTALL(FILES ${DBOPT_FILE} DESTINATION data/test COMPONENT DataFiles)
# Install initial database on windows
IF(NOT CMAKE_CROSSCOMPILING)