summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorJon Olav Hauglid <jon.hauglid@oracle.com>2014-10-13 09:52:28 +0200
committerJon Olav Hauglid <jon.hauglid@oracle.com>2014-10-13 09:52:28 +0200
commit8b64f825058a2439903e9420552641ca6105d9d6 (patch)
tree5e4595b95c1636b3a7f3d889de96da08676d4b19 /sql/CMakeLists.txt
parenta3cc647dbdbdeb0f2e9c9ac55ffe062c659d82dc (diff)
downloadmariadb-git-8b64f825058a2439903e9420552641ca6105d9d6.tar.gz
Bug#17633291: SET PROPER COMPILE OPTIONS FOR CLANG
Bug#17959689: MAKE GCC AND CLANG GIVE CONSISTENT COMPILATION WARNINGS Bug#18313717: ENABLE -WERROR IN MAINTANER MODE WHEN COMPILING WITH CLANG Bug#18510941: REMOVE CMAKE WORKAROUNDS FOR OLDER VERSIONS OF OS X/XCODE Backport from mysql-5.6 to mysql-5.5
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index c19ea9b17bd..030f183d5f7 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -80,6 +80,14 @@ SET (SQL_SOURCE
${GEN_SOURCES}
${MYSYS_LIBWRAP_SOURCE})
+# These files have unused result errors, so we skip Werror
+CHECK_C_COMPILER_FLAG("-Werror" HAVE_WERROR_FLAG)
+IF(HAVE_WERROR_FLAG)
+ INCLUDE(${MYSQL_CMAKE_SCRIPT_DIR}/compile_flags.cmake)
+ ADD_COMPILE_FLAGS(filesort.cc COMPILE_FLAGS "-Wno-error")
+ ADD_COMPILE_FLAGS(opt_range.cc COMPILE_FLAGS "-Wno-error")
+ENDIF()
+
MYSQL_ADD_PLUGIN(partition ha_partition.cc STORAGE_ENGINE DEFAULT STATIC_ONLY
RECOMPILE_FOR_EMBEDDED)