summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authoriggy@recycle.(none) <>2007-04-23 16:23:32 -0400
committeriggy@recycle.(none) <>2007-04-23 16:23:32 -0400
commit13b54aa9634fc0a28269e550a15b6f5104859e44 (patch)
treec97ca12e6aef03d8d4bfc224962e2081cf8ed86f /sql/CMakeLists.txt
parent658d2127e5d434a3d9919a3193292743b0700f30 (diff)
downloadmariadb-git-13b54aa9634fc0a28269e550a15b6f5104859e44.tar.gz
Bug#24732 Executables do not include Vista manifests
- Post merge cleanup.
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index fe919d6442d..cd1a5527abc 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -12,6 +12,7 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+INCLUDE("${PROJECT_SOURCE_DIR}/win/mysql_manifest.cmake")
SET(CMAKE_CXX_FLAGS_DEBUG
"${CMAKE_CXX_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX -DUSE_SYMDIR")
@@ -82,6 +83,10 @@ ADD_EXECUTABLE(mysqld ../sql-common/client.c derror.cc des_key_file.cc
${PROJECT_SOURCE_DIR}/sql/lex_hash.h)
TARGET_LINK_LIBRARIES(mysqld heap myisam myisammrg mysys yassl zlib dbug yassl
taocrypt strings vio regex wsock32 ws2_32)
+
+IF(EMBED_MANIFESTS)
+ MYSQL_EMBED_MANIFEST("mysqld" "requireAdministrator")
+ENDIF(EMBED_MANIFESTS)
IF(WITH_ARCHIVE_STORAGE_ENGINE)
TARGET_LINK_LIBRARIES(mysqld archive)
ENDIF(WITH_ARCHIVE_STORAGE_ENGINE)