summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2008-10-23 15:28:53 +0200
committerVladislav Vaintroub <vvaintroub@mysql.com>2008-10-23 15:28:53 +0200
commit49ff055736b3b613005e5b17915d08fe48b7b532 (patch)
treedb430586277a725560fc7a2845f21b691e5ea119 /sql/Makefile.am
parentd501f48757f891873bccedb7914d1348a981e0f6 (diff)
downloadmariadb-git-49ff055736b3b613005e5b17915d08fe48b7b532.tar.gz
Bug#40280: Message compiler(mc.exe) needed to compile MySQL on windows.
Visual Studio 2008 Express edition does not include message compiler mc.exe It is not possible to build MySQL server if only VC2008 Express is installed, because we use mc.exe to generate event log messages. This patch removes the mc.exe dependency. Generated files message.h, message.rc and MSG00001.bin are checked into source code repository. Instructions on how to add or change messages are added to messages.mc
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 52a4c96f451..96cdd04d5ba 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -118,7 +118,8 @@ DEFS = -DMYSQL_SERVER \
BUILT_SOURCES = sql_yacc.cc sql_yacc.h lex_hash.h
EXTRA_DIST = $(BUILT_SOURCES) nt_servc.cc nt_servc.h \
- message.mc examples/CMakeLists.txt CMakeLists.txt \
+ message.mc message.h message.rc MSG00001.bin \
+ examples/CMakeLists.txt CMakeLists.txt \
udf_example.c udf_example.def
DISTCLEANFILES = lex_hash.h sql_yacc.output