summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2007-02-15 15:45:45 +0100
committerunknown <msvensson@neptunus.(none)>2007-02-15 15:45:45 +0100
commit109bd52ea357e87f3e1c9f6bd1fbcad1b3ffddd4 (patch)
tree54ce7d945351278ad0948075277f67c311ef88a0 /sql/Makefile.am
parent9590b3384a445cc1ae90bbf0252f33082c808503 (diff)
parentf1b8bea142a9983ea5c067afc23a0c5df84a9f0b (diff)
downloadmariadb-git-109bd52ea357e87f3e1c9f6bd1fbcad1b3ffddd4.tar.gz
Merge neptunus.(none):/home/msvensson/mysql/bug10777/my51-bug10777
into neptunus.(none):/home/msvensson/mysql/mysql-5.1-maint sql/Makefile.am: Auto merged
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 43331e3d0c9..f68ddba006a 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -26,7 +26,7 @@ INCLUDES = @ZLIB_INCLUDES@ \
WRAPLIBS= @WRAPLIBS@
SUBDIRS = share
libexec_PROGRAMS = mysqld
-noinst_PROGRAMS = gen_lex_hash
+EXTRA_PROGRAMS = gen_lex_hash
bin_PROGRAMS = mysql_tzinfo_to_sql
gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
SUPPORTING_LIBS = $(top_builddir)/vio/libvio.a \
@@ -150,11 +150,13 @@ link_sources: mysql_tzinfo_to_sql.cc
mysql_tzinfo_to_sql.o: $(mysql_tzinfo_to_sql_SOURCES)
$(CXXCOMPILE) -c $(INCLUDES) -DTZINFO2SQL $<
-# FIXME seems like now "lex_hash.h" differs depending on configure
-# flags, so can't pregenerate and include in source TAR. Revert to
-# dist pregenerated if this changes, so the file doesn't differ.
-lex_hash.h: gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
+ ./gen_lex_hash$(EXEEXT) > $@-t
+ $(MV) $@-t $@
# the following three should eventually be moved out of this directory
ha_ndbcluster.o:ha_ndbcluster.cc ha_ndbcluster.h