summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authormats@romeo.(none) <>2007-04-13 14:55:28 +0200
committermats@romeo.(none) <>2007-04-13 14:55:28 +0200
commit84ec7be2c72df28aac7e68a33c0f4bd0a3972bc8 (patch)
treea6298adece79b18afd126eeb524928c260641fc1 /sql/Makefile.am
parent6044deb72eaf83d44e5a7bf259a50754dfe7fee1 (diff)
downloadmariadb-git-84ec7be2c72df28aac7e68a33c0f4bd0a3972bc8.tar.gz
WL#2735: Refactor replication
Factoring out pack_row() and unpack_row() into new files rpl_record.{cc,h}.
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 0656c1a8f9b..037986e3e45 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -57,8 +57,8 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
log.h sql_show.h rpl_rli.h rpl_mi.h \
sql_select.h structs.h table.h sql_udf.h hash_filo.h \
lex.h lex_symbol.h sql_acl.h sql_crypt.h \
- log_event.h sql_repl.h slave.h rpl_filter.h \
- rpl_injector.h \
+ sql_repl.h slave.h rpl_filter.h rpl_injector.h \
+ log_event.h rpl_record.h \
log_event_old.h rpl_record_old.h \
stacktrace.h sql_sort.h sql_cache.h set_var.h \
spatial.h gstream.h client_settings.h tzfile.h \
@@ -87,8 +87,9 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
sql_prepare.cc sql_error.cc sql_locale.cc \
sql_update.cc sql_delete.cc uniques.cc sql_do.cc \
procedure.cc sql_test.cc \
- log.cc log_event.cc init.cc derror.cc sql_acl.cc \
+ log.cc init.cc derror.cc sql_acl.cc \
unireg.cc des_key_file.cc \
+ log_event.cc rpl_record.cc \
log_event_old.cc rpl_record_old.cc \
discover.cc time.cc opt_range.cc opt_sum.cc \
records.cc filesort.cc handler.cc \