summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <dlenev@brandersnatch.localdomain>2004-06-23 13:07:00 +0400
committerunknown <dlenev@brandersnatch.localdomain>2004-06-23 13:07:00 +0400
commit0fe7f344ea4945ac64ad5ab82778c1e4e98959ab (patch)
tree83120ce0943ee66a4841bc37a509b46da466f483 /sql/Makefile.am
parent5adf6574bd1cfb02834a699a5794038a40773ee0 (diff)
downloadmariadb-git-0fe7f344ea4945ac64ad5ab82778c1e4e98959ab.tar.gz
Final solution to mysql_tzinfo_to_sql problem.
sql/Makefile.am: Final solution to mysql_tzinfo_to_sql problem: We can't put it in extra/ directory since it depends on sql/sql_yacc.h and sql/ directory depends on extra/comp_err. So this utility have to stay in sql/ for a while. BitKeeper/etc/ignore: Added sql/mysql_tzinfo_to_sql_tztime.cc to the ignore list
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index b96f3a63aeb..9fecf6a0d8f 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -27,6 +27,7 @@ WRAPLIBS= @WRAPLIBS@
SUBDIRS = share
libexec_PROGRAMS = mysqld
noinst_PROGRAMS = gen_lex_hash
+bin_PROGRAMS = mysql_tzinfo_to_sql
gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
LDADD = @isam_libs@ \
../myisam/libmyisam.a \
@@ -92,6 +93,10 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc \
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)
+mysql_tzinfo_to_sql_SOURCES = mysql_tzinfo_to_sql_tztime.cc
+mysql_tzinfo_to_sql_CXXFLAGS = -DTZINFO2SQL $(AM_CXXFLAGS)
+mysql_tzinfo_to_sql_LDADD = $(LDADD) $(CXXLDFLAGS)
+
DEFS = -DMYSQL_SERVER \
-DDEFAULT_MYSQL_HOME="\"$(MYSQLBASEdir)\"" \
-DDATADIR="\"$(MYSQLDATAdir)\"" \
@@ -113,6 +118,10 @@ link_sources:
gen_lex_hash.o: gen_lex_hash.cc lex.h
$(CXXCOMPILE) -c $(INCLUDES) $<
+mysql_tzinfo_to_sql_tztime.cc: tztime.cc
+ rm -f $(srcdir)/mysql_tzinfo_to_sql_tztime.cc
+ @LN_CP_F@ $(srcdir)/tztime.cc $(srcdir)/mysql_tzinfo_to_sql_tztime.cc
+
# Try to get better dependencies for the grammar. Othervise really bad
# things like different grammars for different pars of MySQL can
# happen if you are unlucky.