summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@avenger.(none)>2004-05-20 18:13:11 -0700
committerunknown <brian@avenger.(none)>2004-05-20 18:13:11 -0700
commit31c1f849b13cf45575484856622dcc609669f2ff (patch)
tree45ea3f6b8edb44c6f6648d781eace4b0acc6d0aa /sql/Makefile.am
parentf10d01a747267e169d9f0b80d30a71b00f0bce7c (diff)
downloadmariadb-git-31c1f849b13cf45575484856622dcc609669f2ff.tar.gz
First commit of archive example. Archive is a simple storage engine that handles inserts and selects.
acconfig.h: Adding undef piece for HAVE_ARCHIVE_DB acinclude.m4: Code needed for --with-archive-storage-engine flag for compile. configure.in: Adding tag for Archive sql/Makefile.am: Source updates to compile ha_archive sql/examples/ha_archive.cc: Class file for archive storage engine. First version. sql/handler.cc: Updates needed for adding archive storage engine. sql/handler.h: ENUM for archive storage engine. sql/mysql_priv.h: Archive show options sql/mysqld.cc: Ifdef foor HAVE_ARCHIVE_DB sql/examples/ha_archive.h: Include file for archive storage engine addition. BitKeeper/etc/logging_ok: Logging to logging@openlogging.org accepted
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index bacf3bc58d1..f56ab646c09 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -58,7 +58,7 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
log_event.h sql_repl.h slave.h \
stacktrace.h sql_sort.h sql_cache.h set_var.h \
spatial.h gstream.h client_settings.h \
- examples/ha_example.h
+ examples/ha_example.h examples/ha_archive.h
mysqld_SOURCES = sql_lex.cc sql_handler.cc \
item.cc item_sum.cc item_buff.cc item_func.cc \
item_cmpfunc.cc item_strfunc.cc item_timefunc.cc \
@@ -88,7 +88,7 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc \
client.c sql_client.cc mini_client_errors.c pack.c\
stacktrace.c repl_failsafe.h repl_failsafe.cc sql_olap.cc\
gstream.cc spatial.cc sql_help.cc protocol_cursor.cc \
- examples/ha_example.cc
+ examples/ha_example.cc examples/ha_archive.cc
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)