summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2005-01-28 17:14:03 +0100
committerunknown <serg@serg.mylan>2005-01-28 17:14:03 +0100
commit5c3c40798dce878bd6561b8da6a5e1cbd9f16279 (patch)
tree9cc656a413f403a59b9dfda94e260b6e2158c288 /sql/Makefile.am
parent085f70728768abc2f25ad46a329a6659c17088bc (diff)
downloadmariadb-git-5c3c40798dce878bd6561b8da6a5e1cbd9f16279.tar.gz
small Makefile.am cleanup
clean: targets removed generated *.h files moved to include/ Docs/Images/Makefile.am: no clean: targets please! client/Makefile.am: generated *.h files moved to include/ extra/Makefile.am: generated *.h files moved to include/ include/Makefile.am: no clean: targets please! libmysql/Makefile.am: generated *.h files moved to include/ libmysql_r/Makefile.am: generated *.h files moved to include/ libmysqld/Makefile.am: generated *.h files moved to include/ libmysqld/examples/Makefile.am: generated *.h files moved to include/ no clean: target please! ndb/docs/Makefile.am: no clean: targets please! scripts/Makefile.am: SUPERCLEANFILES means nothing server-tools/instance-manager/Makefile.am: generated *.h files moved to include/ sql/Makefile.am: generated *.h files moved to include/ sql/share/Makefile.am: instead of (incorrectly) duplicating comp_err command line, call do make in extra/ tools/Makefile.am: generated *.h files moved to include/ BitKeeper/etc/ignore: Added include/mysqld_ername.h include/mysqld_error.h include/sql_state.h to the ignore list
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 8ff55898ba4..3c520ac971c 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -22,7 +22,7 @@ MYSQLBASEdir= $(prefix)
INCLUDES = @MT_INCLUDES@ @ZLIB_INCLUDES@ \
@bdb_includes@ @innodb_includes@ @ndbcluster_includes@ \
-I$(top_srcdir)/include -I$(top_srcdir)/regex \
- -I$(srcdir) $(openssl_includes) -I$(top_srcdir)/extra
+ -I$(srcdir) $(openssl_includes) -I$(top_builddir)/include
WRAPLIBS= @WRAPLIBS@
SUBDIRS = share
libexec_PROGRAMS = mysqld
@@ -115,6 +115,7 @@ DEFS = -DMYSQL_SERVER \
# Don't put lex_hash.h in BUILT_SOURCES as this will give infinite recursion
BUILT_SOURCES = sql_yacc.cc sql_yacc.h
EXTRA_DIST = udf_example.cc $(BUILT_SOURCES)
+DISTCLEANFILES = lex_hash.h
AM_YFLAGS = -d
mysql_tzinfo_to_sql.cc:
@@ -160,8 +161,5 @@ sql_lex.o: lex_hash.h
udf_example.so: udf_example.cc
$(CXXCOMPILE) -shared -o $@ $<
-distclean:
- rm -f lex_hash.h
-
# Don't update the files from bitkeeper
%::SCCS/s.%