summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authormsvensson@neptunus.(none) <>2006-09-25 20:01:39 +0200
committermsvensson@neptunus.(none) <>2006-09-25 20:01:39 +0200
commit5edd58b14c9c7217bfd397f6479202c147c6682c (patch)
tree54b4ae664ca32822f10ea03fc8e1fed97e90f294 /sql/Makefile.am
parent635281619b73801417cec034f46a31d09cbbd298 (diff)
downloadmariadb-git-5edd58b14c9c7217bfd397f6479202c147c6682c.tar.gz
Bug#18888 Trying to overwrite sql/lex_hash.h during build
-Backport fix for bug19738 to 4.1
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 9e512c362a9..43a7617df52 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -26,7 +26,7 @@ INCLUDES = @MT_INCLUDES@ @ZLIB_INCLUDES@ \
WRAPLIBS= @WRAPLIBS@
SUBDIRS = share
libexec_PROGRAMS = mysqld
-noinst_PROGRAMS = gen_lex_hash
+EXTRA_PROGRAMS = gen_lex_hash
bin_PROGRAMS = mysql_tzinfo_to_sql
gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
LDADD = @isam_libs@ \
@@ -137,7 +137,11 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
# For testing of udf_example.so; Works on platforms with gcc