summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2007-02-07 09:46:20 +0100
committerunknown <msvensson@neptunus.(none)>2007-02-07 09:46:20 +0100
commit772e03c2256f254330adbcc085ba4e1a7ee2f29e (patch)
treee6f59604e82225a9edbbf03262a6ca67695f15e6 /sql/Makefile.am
parent0dc19dadb9a75978addacf54f671901245105c14 (diff)
downloadmariadb-git-772e03c2256f254330adbcc085ba4e1a7ee2f29e.tar.gz
Bug#10777 ERROR File = sql_lex.cc, Line = 93 The identifier "symbols" is undefined.
- Protect againt empty/corrupt lex_hash-h by writing output from gen_lex_hash to a temporary file first. sql/Makefile.am: Protect against empty lex_hash.h due to failed execution of gen_lex_hash by writing outpout to a tmp file first
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 43a7617df52..cf7bc0a1452 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -142,7 +142,8 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
# this avoid the rebuild of the built files in a source dist
lex_hash.h: gen_lex_hash.cc lex.h
$(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@
+ ./gen_lex_hash$(EXEEXT) > $@-t
+ $(MV) $@-t $@
# For testing of udf_example.so; Works on platforms with gcc
# (This is not part of our build process but only provided as an example)