summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorMySQL Build Team <build@mysql.com>2009-01-28 00:04:05 +0100
committerMySQL Build Team <build@mysql.com>2009-01-28 00:04:05 +0100
commit55cbf08aed37f269198270e4233f3037ba3f5707 (patch)
treec391451efa93eb6ac3e7fbc8e3649e2595291d89 /sql/Makefile.am
parenteead3aead1156f8c742fe3401dff5c741ded520e (diff)
downloadmariadb-git-55cbf08aed37f269198270e4233f3037ba3f5707.tar.gz
Fix dependency issue for dtrace
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 6a5a0d16172..d05e0efbcba 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -226,8 +226,10 @@ probes_all.o: probes_mysql.d $(DTRACEFILES)
objects=`for i in $(DTRACEDIRS); do f=\`cat $$i/dtrace_files 2>/dev/null\`; for j in $$f; do test -f $$i/$$j && echo "$$i/$$j "; done; done`; \
$(DTRACE) $(DTRACEFLAGS) -G $$providers $$objects -o $@
-probes_libndb.o: probes_mysql.d
- $(DTRACE) $(DTRACEFLAGS) -G -s $^ .libs/libndb_la-ha_ndbcluster.o -o $@
+# Can't depend directly on .libs/*.o, because there is no generated rule for
+# that in the Makefile; it is a byproduct of *.lo
+probes_libndb.o: probes_mysql.d libndb_la-ha_ndbcluster.lo
+ $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d .libs/libndb_la-ha_ndbcluster.o -o $@
endif
# Don't update the files from bitkeeper