summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2009-12-11 15:51:39 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2009-12-11 15:51:39 +0100
commit55ccb35ba66e4e9168c412c95ebbb85106db8b2c (patch)
treefa038e3ac6dc4935686d55c7c0d764d5b0db0b64 /sql/Makefile.am
parent1ec457961df55720e465a46f5ee340654429bed1 (diff)
downloadmariadb-git-55ccb35ba66e4e9168c412c95ebbb85106db8b2c.tar.gz
Introduce a workaround for Solaris' inability to deal with dtrace in static libraries.
Rerun dtrace -G on all objects that can contan dtrace probes (also objects that are part of static libs) before linking mysqld to produce dtrace_probes_all.o and link dtrace_probes_all.o with mysqld This ugly workaround was inspired by handling dtrace using autotools.
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 15ee0d588c4..5f5b8de97be 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -123,7 +123,7 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
net_serv.cc protocol.cc sql_state.c \
lock.cc my_lock.c \
sql_string.cc sql_manager.cc sql_map.cc \
- mysqld.cc password.c hash_filo.cc hostname.cc \
+ main.cc mysqld.cc password.c hash_filo.cc hostname.cc \
sql_connect.cc scheduler.cc sql_parse.cc \
set_var.cc sql_yacc.yy \
sql_base.cc table.cc sql_select.cc sql_insert.cc \