summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <mskold/marty@mysql.com/linux.site>2007-04-24 14:24:06 +0200
committerunknown <mskold/marty@mysql.com/linux.site>2007-04-24 14:24:06 +0200
commitbe5a3426bcffeecafdea2860c182e13ef813d634 (patch)
tree03b91c4c17538204deb7f2a1c0bca9726b3688b4 /sql/Makefile.am
parent5506f6ca8b50ee2fc5e5cdf654834de5b1197659 (diff)
downloadmariadb-git-be5a3426bcffeecafdea2860c182e13ef813d634.tar.gz
ha_ndbcluster.h, ha_ndbcluster.cc:
Refactored code for engine_condition_pushdown to ha_ndbcluster_cond Makefile.am: Added compilation of ha_ndbcluster_cond ha_ndbcluster_cond.h, ha_ndbcluster_cond.cc: Merge libmysqld/Makefile.am: Added compilation of ha_ndbcluster_cond sql/Makefile.am: Added compilation of ha_ndbcluster_cond sql/ha_ndbcluster.cc: Refactored code for engine_condition_pushdown to ha_ndbcluster_cond sql/ha_ndbcluster.h: Refactored code for engine_condition_pushdown to ha_ndbcluster_cond sql/ha_ndbcluster_cond.cc: Merge sql/ha_ndbcluster_cond.h: Merge
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 5f0b9476c01..1849587962e 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -48,9 +48,9 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
procedure.h sql_class.h sql_lex.h sql_list.h \
sql_map.h sql_string.h unireg.h \
sql_error.h field.h handler.h mysqld_suffix.h \
- ha_partition.h \
- ha_ndbcluster.h ha_ndbcluster_binlog.h \
- ha_ndbcluster_tables.h rpl_constants.h \
+ ha_ndbcluster.h ha_ndbcluster_cond.h \
+ ha_ndbcluster_binlog.h ha_ndbcluster_tables.h
+ ha_partition.h rpl_constants.h \
opt_range.h protocol.h rpl_tblmap.h rpl_utility.h \
log.h sql_show.h rpl_rli.h rpl_mi.h \
sql_select.h structs.h table.h sql_udf.h hash_filo.h \
@@ -89,8 +89,8 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
unireg.cc des_key_file.cc \
discover.cc time.cc opt_range.cc opt_sum.cc \
records.cc filesort.cc handler.cc \
- ha_partition.cc \
- ha_ndbcluster.cc ha_ndbcluster_binlog.cc \
+ ha_ndbcluster.cc ha_ndbcluster_cond.cc \
+ ha_ndbcluster_binlog.cc ha_partition.cc \
sql_db.cc sql_table.cc sql_rename.cc sql_crypt.cc \
sql_load.cc mf_iocache.cc field_conv.cc sql_show.cc \
sql_udf.cc sql_analyse.cc sql_analyse.h sql_cache.cc \
@@ -153,10 +153,13 @@ lex_hash.h: gen_lex_hash.cc lex.h
./gen_lex_hash$(EXEEXT) > $@-t
$(MV) $@-t $@
-# the following three should eventually be moved out of this directory
+# the following four should eventually be moved out of this directory
ha_ndbcluster.o:ha_ndbcluster.cc ha_ndbcluster.h
$(CXXCOMPILE) @ndbcluster_includes@ $(LM_CFLAGS) -c $<
+ha_ndbcluster_cond.o:ha_ndbcluster_cond.cc ha_ndbcluster_cond.h
+ $(CXXCOMPILE) @ndbcluster_includes@ $(LM_CFLAGS) -c $<
+
ha_ndbcluster_binlog.o:ha_ndbcluster_binlog.cc ha_ndbcluster_binlog.h
$(CXXCOMPILE) @ndbcluster_includes@ $(LM_CFLAGS) -c $<