summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorMikael Ronstrom <mikael@mysql.com>2009-03-06 13:22:25 +0100
committerMikael Ronstrom <mikael@mysql.com>2009-03-06 13:22:25 +0100
commit1ad9b0fa4fb2d0b46d0064ed667433335451f900 (patch)
treed68a715abea7133e2c6a80899cfe0ba062ab4311 /sql/Makefile.am
parentae3bafc9f8e3f54d2bb57704ec8ec6ceb8c87ebc (diff)
downloadmariadb-git-1ad9b0fa4fb2d0b46d0064ed667433335451f900.tar.gz
Ensured that we apply DTrace script on both object files potentially
produced by libtool
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index cee2c37fd2e..cca02ecc47a 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -248,7 +248,13 @@ probes_all.o: probes_mysql.d $(DTRACEFILES_DEPEND)
# Can't depend directly on .libs/*.o, because there is no generated rule for
# that in the Makefile; it is a byproduct of *.lo
probes_libndb.o: probes_mysql.d libndb_la-ha_ndbcluster.lo
- $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d .libs/libndb_la-ha_ndbcluster.o -o $@
+ if test -f .libs/libndb_la-ha_ndbcluster.o ; then
+ $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d .libs/libndb_la-ha_ndbcluster.o -o $@
+ endif
+ if test -f libndb_la-ha_ndbcluster.o ; then
+ $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d libndb_la-ha_ndbcluster.o -o $@
+ endif
+
endif
# Don't update the files from bitkeeper