summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/c-4b4072d5.010-2112-6f72651.cust.bredbandsbolaget.se>2006-07-29 04:41:50 +0200
committerunknown <kent@mysql.com/c-4b4072d5.010-2112-6f72651.cust.bredbandsbolaget.se>2006-07-29 04:41:50 +0200
commit3c9ba0208ae236435f5bad462b41f0df72aaad28 (patch)
tree077b41d8a23beb49eeba63c4589c3fbec2551907 /sql/Makefile.am
parent8c4ba9687f8b101d9ea43ea0200582477e52e679 (diff)
downloadmariadb-git-3c9ba0208ae236435f5bad462b41f0df72aaad28.tar.gz
udf_example.c, udf.test, Makefile.am:
Converted "udf_example.cc" to C, avoids C++ runtime lib dependency (bug#21336) sql/Makefile.am: "udf_example.cc" converted to C, avoids C++ runtime lib dependency (bug#21336) mysql-test/t/udf.test: "udf_example.cc" converted to C, avoids C++ runtime lib dependency (bug#21336) sql/udf_example.c: Changes to be strict ansi, except long long
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 416f0faf1a6..8428d6401b5 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -116,7 +116,7 @@ DEFS = -DMYSQL_SERVER \
@DEFS@
BUILT_SOURCES = sql_yacc.cc sql_yacc.h lex_hash.h
-EXTRA_DIST = udf_example.cc $(BUILT_SOURCES)
+EXTRA_DIST = $(BUILT_SOURCES)
DISTCLEANFILES = lex_hash.h
AM_YFLAGS = -d
@@ -155,7 +155,7 @@ lex_hash.h: gen_lex_hash$(EXEEXT)
# For testing of udf_example.so
noinst_LTLIBRARIES= udf_example.la
-udf_example_la_SOURCES= udf_example.cc
+udf_example_la_SOURCES= udf_example.c
udf_example_la_LDFLAGS= -module -rpath $(pkglibdir)