summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <mats@romeo.(none)>2007-04-12 15:50:54 +0200
committerunknown <mats@romeo.(none)>2007-04-12 15:50:54 +0200
commit5c35b4174ef8a3505f927444ec9001848b3073be (patch)
tree99bc39551e216b0f815a7d3af2d4237c7ed72cc9 /sql/Makefile.am
parentec9b5eca9cee569eb4c1442cb0ab47c72dac818d (diff)
downloadmariadb-git-5c35b4174ef8a3505f927444ec9001848b3073be.tar.gz
BUG#27779 (Slave cannot read old rows log events):
Taking code from before BUG#22583 and incorporating as events to be able to read old events. Also incorporating old pack and unpack functions into patch. client/Makefile.am: Adding files log_event_old.{h,cc} and rpl_record_old.{h,cc} client/mysqlbinlog.cc: Adding log_event_old.cc. libmysqld/Makefile.am: Adding files log_event_old.{h,cc} and rpl_record_old.{h,cc} sql/CMakeLists.txt: Adding files log_event_old.{h,cc} and rpl_record_old.{h,cc} sql/Makefile.am: Adding files log_event_old.{h,cc} and rpl_record_old.{h,cc} sql/log_event.cc: Adding code to read pre-GA rows events. sql/log_event.h: Refactoring to support inheritance and including "old" events definitions. sql/log_event_old.cc: New BitKeeper file ``sql/log_event_old.cc'' sql/log_event_old.h: New BitKeeper file ``sql/log_event_old.h'' sql/rpl_record_old.cc: New BitKeeper file ``sql/rpl_record_old.cc'' sql/rpl_record_old.h: New BitKeeper file ``sql/rpl_record_old.h''
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index a85eb012f1d..0656c1a8f9b 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -59,6 +59,7 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
lex.h lex_symbol.h sql_acl.h sql_crypt.h \
log_event.h sql_repl.h slave.h rpl_filter.h \
rpl_injector.h \
+ log_event_old.h rpl_record_old.h \
stacktrace.h sql_sort.h sql_cache.h set_var.h \
spatial.h gstream.h client_settings.h tzfile.h \
tztime.h my_decimal.h\
@@ -88,6 +89,7 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
procedure.cc sql_test.cc \
log.cc log_event.cc init.cc derror.cc sql_acl.cc \
unireg.cc des_key_file.cc \
+ log_event_old.cc rpl_record_old.cc \
discover.cc time.cc opt_range.cc opt_sum.cc \
records.cc filesort.cc handler.cc \
ha_partition.cc \