summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authormsvensson@neptunus.(none) <>2007-02-07 09:46:20 +0100
committermsvensson@neptunus.(none) <>2007-02-07 09:46:20 +0100
commit72408c88bd1ce9c25cfa5391e847f0c1880372fe (patch)
treee6f59604e82225a9edbbf03262a6ca67695f15e6 /sql/Makefile.am
parent972df14cc6554a4950085d1c94ca1fe738583988 (diff)
downloadmariadb-git-72408c88bd1ce9c25cfa5391e847f0c1880372fe.tar.gz
Bug#10777 ERROR File = sql_lex.cc, Line = 93 The identifier "symbols" is undefined.
- Protect againt empty/corrupt lex_hash-h by writing output from gen_lex_hash to a temporary file first.
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 43a7617df52..cf7bc0a1452 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -142,7 +142,8 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
# this avoid the rebuild of the built files in a source dist
lex_hash.h: gen_lex_hash.cc lex.h
$(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@
+ ./gen_lex_hash$(EXEEXT) > $@-t
+ $(MV) $@-t $@
# For testing of udf_example.so; Works on platforms with gcc
# (This is not part of our build process but only provided as an example)