summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2005-03-22 16:10:39 -0800
committerunknown <brian@zim.(none)>2005-03-22 16:10:39 -0800
commit8a99997d6061ec3e2d75616422eac413868ceada (patch)
tree5c6b4d736e4b7ef46a5f108c4b75ea97249d7398 /sql/Makefile.am
parent5b32b8e1dd281d15de4ccafb23dde29b43303850 (diff)
downloadmariadb-git-8a99997d6061ec3e2d75616422eac413868ceada.tar.gz
Additional storage engine called "blackhole". Customer request, and for that matter a Zawodny request. With this you can alter table to a type of table that would never store data. Its a /dev/null for a database.
acinclude.m4: New macro rule for ha_blackhole. configure.in: Rule enabling blackhole engine sql/Makefile.am: Additions to Makefile for blackhole engine sql/handler.cc: Ifdef enable code for blackhole (and message for "what does this thing do"). sql/handler.h: Flag for storage engine type. sql/mysql_priv.h: Added blackhole type. sql/mysqld.cc: Updates for building backhole. sql/set_var.cc: Show variable for blackhole engine
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 19bdf8055f3..f812bbe72af 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -60,7 +60,7 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
stacktrace.h sql_sort.h sql_cache.h set_var.h \
spatial.h gstream.h client_settings.h tzfile.h \
tztime.h examples/ha_example.h examples/ha_archive.h \
- examples/ha_tina.h
+ examples/ha_tina.h ha_blackhole.h
mysqld_SOURCES = sql_lex.cc sql_handler.cc \
item.cc item_sum.cc item_buff.cc item_func.cc \
item_cmpfunc.cc item_strfunc.cc item_timefunc.cc \
@@ -92,7 +92,7 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc \
gstream.cc spatial.cc sql_help.cc protocol_cursor.cc \
tztime.cc my_time.c \
examples/ha_example.cc examples/ha_archive.cc \
- examples/ha_tina.cc
+ examples/ha_tina.cc ha_blackhole.cc
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)