summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2003-06-20 15:19:51 +0200
committerunknown <lenz@mysql.com>2003-06-20 15:19:51 +0200
commit4161b5a633dc9d8b1f8e2a9ae384f514336b48d1 (patch)
treeb26952b4e95ae36d6454c55b979698e8e42c8cdb /sql/Makefile.am
parent92542bb071c9411f35f6b5d3445d6801724f332e (diff)
downloadmariadb-git-4161b5a633dc9d8b1f8e2a9ae384f514336b48d1.tar.gz
- added $(EXEEXT) to gen_lex_hash generation/execution to fix a build
problem on Windows/cygwin (BUG#668)
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index a589f1379f9..e2494e50d96 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -114,8 +114,8 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
lex_hash.h: lex.h gen_lex_hash.cc sql_yacc.h
- $(MAKE) gen_lex_hash
- ./gen_lex_hash > $@
+ $(MAKE) gen_lex_hash$(EXEEXT)
+ ./gen_lex_hash$(EXEEXT) > $@
# Hack to ensure that lex_hash.h is built early
sql_lex.o: lex_hash.h