summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent/mysqldev@mysql.com/production.mysql.com>2008-04-02 00:43:17 +0200
committerunknown <kent/mysqldev@mysql.com/production.mysql.com>2008-04-02 00:43:17 +0200
commit60e5661361070701b374b7e48229b7b3f07492b2 (patch)
treee3735a198e8fd501c1281007ade11a18a59b2ad2 /sql/Makefile.am
parentc8c28c50159def13029d665d1b0351be2fa416d1 (diff)
downloadmariadb-git-60e5661361070701b374b7e48229b7b3f07492b2.tar.gz
mysqld.cc:
Corrects build problems embedded on Windows Makefile.am: Install .sym or mysqld-debug if exists query_cache_debug.test, query_cache_debug.result: Set more resonable query cache size (bug#35749) CMakeLists.txt: Added missing stacktrace.c mysql-test/r/query_cache_debug.result: Set more resonable query cache size (bug#35749) mysql-test/t/query_cache_debug.test: Set more resonable query cache size (bug#35749) libmysqld/CMakeLists.txt: Added missing stacktrace.c sql/Makefile.am: Install .sym or mysqld-debug if exists sql/mysqld.cc: Corrects build problems embedded on Windows
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 3a6f4bcb7a2..33664b77957 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -54,7 +54,7 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
procedure.h sql_class.h sql_lex.h sql_list.h \
sql_map.h sql_string.h unireg.h \
sql_error.h field.h handler.h mysqld_suffix.h \
- sql_profile.h \
+ sql_profile.h \
ha_ndbcluster.h ha_ndbcluster_cond.h \
ha_ndbcluster_binlog.h ha_ndbcluster_tables.h \
ha_partition.h rpl_constants.h \
@@ -178,6 +178,12 @@ lex_hash.h: gen_lex_hash.cc lex.h
udf_example_la_SOURCES= udf_example.c
udf_example_la_LDFLAGS= -module -rpath $(pkglibdir)
+# We might have some stuff not built in this build, but that we want to install
+install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(libexecdir) $(DESTDIR)$(pkglibdir)
+ test ! -x mysqld-debug$(EXEEXT) || $(INSTALL_PROGRAM) mysqld-debug$(EXEEXT) $(DESTDIR)$(libexecdir)
+ test ! -f mysqld-debug.sym.gz || $(INSTALL_DATA) mysqld-debug.sym.gz $(DESTDIR)$(pkglibdir)
+ test ! -f mysqld.sym.gz || $(INSTALL_DATA) mysqld.sym.gz $(DESTDIR)$(pkglibdir)
# Don't update the files from bitkeeper
%::SCCS/s.%