summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@shellback.(none)>2006-09-18 21:55:20 +0200
committerunknown <msvensson@shellback.(none)>2006-09-18 21:55:20 +0200
commitfc78e7ffeea235db1557599383e8dc376a2dbe6e (patch)
tree60313d9815622fa27c82653744b256c96b565f68 /sql/Makefile.am
parentd0e1dda11519fd0a7ce0a00d2c4102c886cb754d (diff)
parentb0b0b7c17907773ce6989a142c9af6197eb9cae7 (diff)
downloadmariadb-git-fc78e7ffeea235db1557599383e8dc376a2dbe6e.tar.gz
Merge shellback.(none):/home/msvensson/mysql/bug19738/my50-bug19738
into shellback.(none):/home/msvensson/mysql/mysql-5.0-maint extra/Makefile.am: Auto merged sql/Makefile.am: Auto merged
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 98c8fe784eb..a317715922d 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -152,7 +152,11 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
# For testing of udf_example.so