summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <cmiller@zippy.cornsilk.net>2006-09-23 09:51:20 -0400
committerunknown <cmiller@zippy.cornsilk.net>2006-09-23 09:51:20 -0400
commitb561dd1e8858b3654a54a7f453bb28b72fd8b984 (patch)
treece6ba7bb00aae15a9d07c437aa7a0ce0f7ef3617 /sql/Makefile.am
parenta5d82874a7292c6023c78f6c2386824c932108a5 (diff)
parent02848f8963b93d28566a252175f5386de9fdd6cd (diff)
downloadmariadb-git-b561dd1e8858b3654a54a7f453bb28b72fd8b984.tar.gz
Merge bk-internal.mysql.com:/home/bk/mysql-5.1
into zippy.cornsilk.net:/home/cmiller/work/mysql/mysql-5.1-maint BitKeeper/etc/ignore: auto-union mysql-test/mysql-test-run.pl: Auto merged mysql-test/t/disabled.def: Auto merged sql/Makefile.am: Auto merged sql/sql_yacc.yy: Auto merged storage/innobase/handler/ha_innodb.cc: Auto merged
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 502d2881eb0..38a99aaef88 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -27,7 +27,7 @@ INCLUDES = @ZLIB_INCLUDES@ \
WRAPLIBS= @WRAPLIBS@
SUBDIRS = share
libexec_PROGRAMS = mysqld
-noinst_PROGRAMS = gen_lex_hash
+EXTRA_PROGRAMS = gen_lex_hash
bin_PROGRAMS = mysql_tzinfo_to_sql
gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
LDADD = $(top_builddir)/vio/libvio.a \
@@ -157,7 +157,11 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
# the following three should eventually be moved out of this directory