summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@brian-akers-computer.local>2004-04-12 21:01:45 -0700
committerunknown <brian@brian-akers-computer.local>2004-04-12 21:01:45 -0700
commit01bff53c4f71b9d204bc42b654e73d4ec6e6a941 (patch)
tree686ebbc1135999578321bffc95e6f3aec84ad720 /sql/Makefile.am
parent83c2292bb5617128bd5c0eaa69663072363b38c7 (diff)
downloadmariadb-git-01bff53c4f71b9d204bc42b654e73d4ec6e6a941.tar.gz
All changes are to allow someone to compile the example storage engine and use it.
acconfig.h: Default undef for example storage engine. acinclude.m4: Build macro additions for example engine. configure.in: Configure changes for it to be listed in --help sql/Makefile.am: Added in paths to build example. sql/examples/ha_example.cc: Correction in indention and a few minor other corrections. It now lets you create/open/drop example engine. sql/handler.cc: Added definition for the example storage engine. Added case for it to be created. sql/handler.h: Added example storage engine type. sql/mysql_priv.h: Added flag for optional build of example storage engine. sql/mysqld.cc: Pieces to build example storage engine.
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 4aa6aaaa1ee..bacf3bc58d1 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -37,7 +37,7 @@ LDADD = @isam_libs@ \
../mysys/libmysys.a \
../dbug/libdbug.a \
../regex/libregex.a \
- ../strings/libmystrings.a
+ ../strings/libmystrings.a
mysqld_LDADD = @MYSQLD_EXTRA_LDFLAGS@ \
@bdb_libs@ @innodb_libs@ @pstack_libs@ \
@@ -57,7 +57,8 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
lex.h lex_symbol.h sql_acl.h sql_crypt.h \
log_event.h sql_repl.h slave.h \
stacktrace.h sql_sort.h sql_cache.h set_var.h \
- spatial.h gstream.h client_settings.h
+ spatial.h gstream.h client_settings.h \
+ examples/ha_example.h
mysqld_SOURCES = sql_lex.cc sql_handler.cc \
item.cc item_sum.cc item_buff.cc item_func.cc \
item_cmpfunc.cc item_strfunc.cc item_timefunc.cc \
@@ -86,7 +87,8 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc \
slave.cc sql_repl.cc sql_union.cc sql_derived.cc \
client.c sql_client.cc mini_client_errors.c pack.c\
stacktrace.c repl_failsafe.h repl_failsafe.cc sql_olap.cc\
- gstream.cc spatial.cc sql_help.cc protocol_cursor.cc
+ gstream.cc spatial.cc sql_help.cc protocol_cursor.cc \
+ examples/ha_example.cc
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)