summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2006-08-18 21:19:19 -0700
committerunknown <brian@zim.(none)>2006-08-18 21:19:19 -0700
commitb470b3ab87743a13470098b8446da3fe2e100c9e (patch)
tree5e3642a4d6fe9f0bfc4b88394c8d2dae810fb30b /sql/Makefile.am
parentbc4215111ca83b8535915c8b8d207fe105b4cb66 (diff)
downloadmariadb-git-b470b3ab87743a13470098b8446da3fe2e100c9e.tar.gz
Major changes are plug.in files created for almost all storage engines. A few stray BDB references removed.
storage/blackhole/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/blackhole/plug.in storage/heap/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/heap/plug.in storage/myisam/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/myisam/plug.in storage/myisammrg/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/myisammrg/plug.in storage/federated/ha_federated.h: Rename: sql/ha_federated.h -> storage/federated/ha_federated.h BUILD/FINISH.sh: Stray BDB reference BUILD/autorun.sh: Stray bdb reference BUILD/compile-alpha-cxx: Stray bdb reference BUILD/compile-alpha-debug: Stray bdb reference BUILD/compile-dist: Stray BDB Reference BUILD/compile-ia64-debug-max: Stray BDB reference configure.in: All plugin code is now in plug.in files. Few tricky exceptions left. sql/CMakeLists.txt: Removed federated references sql/Makefile.am: Removed federated references sql/mysql_priv.h: stray bdb reference storage/example/ha_example.cc: Enabled all of mysql include storage/federated/ha_federated.cc: Added plugin defs storage/csv/plug.in: New BitKeeper file ``storage/csv/plug.in'' storage/federated/Makefile.am: New BitKeeper file ``storage/federated/Makefile.am'' storage/federated/plug.in: New BitKeeper file ``storage/federated/plug.in'' storage/innobase/plug.in: New BitKeeper file ``storage/innobase/plug.in'' storage/ndb/plug.in: New BitKeeper file ``storage/ndb/plug.in''
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 5c509707f51..1d3cca1f626 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -50,7 +50,7 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
sql_map.h sql_string.h unireg.h \
sql_error.h field.h handler.h mysqld_suffix.h \
ha_heap.h ha_myisam.h ha_myisammrg.h ha_partition.h \
- ha_innodb.h ha_federated.h \
+ ha_innodb.h \
ha_ndbcluster.h ha_ndbcluster_binlog.h \
ha_ndbcluster_tables.h \
opt_range.h protocol.h rpl_tblmap.h \
@@ -89,7 +89,6 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
records.cc filesort.cc handler.cc \
ha_heap.cc ha_myisam.cc ha_myisammrg.cc \
ha_partition.cc ha_innodb.cc \
- ha_federated.cc \
ha_ndbcluster.cc ha_ndbcluster_binlog.cc \
sql_db.cc sql_table.cc sql_rename.cc sql_crypt.cc \
sql_load.cc mf_iocache.cc field_conv.cc sql_show.cc \