summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@shellback.(none)>2006-09-18 21:15:38 +0200
committerunknown <msvensson@shellback.(none)>2006-09-18 21:15:38 +0200
commitfb63fdb9eec07e815bda7d94a4d9632ede9380db (patch)
tree4a183e9cbfba58432731bedf02d30c1d4f80d56e /sql/Makefile.am
parente60eba18272d277b951398764f8cd29071f51d2b (diff)
parentb0b0b7c17907773ce6989a142c9af6197eb9cae7 (diff)
downloadmariadb-git-fb63fdb9eec07e815bda7d94a4d9632ede9380db.tar.gz
Merge shellback.(none):/home/msvensson/mysql/bug19738/my50-bug19738
into shellback.(none):/home/msvensson/mysql/bug19738/my51-bug19738 extra/Makefile.am: Auto merged sql/Makefile.am: Auto merged
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index d1ebea45d0c..58960040011 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -154,7 +154,11 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
# the following three should eventually be moved out of this directory