summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authormsvensson@devsrv-b.mysql.com <>2006-03-10 10:41:04 +0100
committermsvensson@devsrv-b.mysql.com <>2006-03-10 10:41:04 +0100
commit1ab7d910033864c4e78f02e9fc98c7fbf7d67bdb (patch)
treebbed8496316f7d96b19be754fe3d12b8acde0584 /sql/Makefile.am
parentfa1f8a9c80be4599c4bf6e45145cf72f7d139b6a (diff)
downloadmariadb-git-1ab7d910033864c4e78f02e9fc98c7fbf7d67bdb.tar.gz
Bug#17261 Passing a variable from a stored procedure to UDF crashes mysqld
- Update of test toolsand Makefiles to make it possible to test always test udf's as part of the mysql test suite
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index d701c18a4d7..9b818f7c389 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -153,10 +153,12 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
lex_hash.h: gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
-# For testing of udf_example.so; Works on platforms with gcc
-# (This is not part of our build process but only provided as an example)
-udf_example.so: udf_example.cc
- $(CXXCOMPILE) -shared -o $@ $<
+# For testing of udf_example.so
+noinst_LTLIBRARIES= udf_example.la
+udf_example_la_SOURCES= udf_example.cc
+udf_example_la_CXXFLAGS= -DSTANDARD
+udf_example_la_LDFLAGS= -module -rpath $(pkglibdir)
+
# Don't update the files from bitkeeper
%::SCCS/s.%