summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <tim@black.box>2001-10-09 18:11:44 -0400
committerunknown <tim@black.box>2001-10-09 18:11:44 -0400
commit0cbaff7b752c186de851bc5f512a43ac8b4dd19d (patch)
tree305dc7d1714dcdcdf3f64ca1e68570c5d11ee6b8 /sql/Makefile.am
parent7291568c0f6f79cd2cee369314fca0024af5dafd (diff)
downloadmariadb-git-0cbaff7b752c186de851bc5f512a43ac8b4dd19d.tar.gz
Add --without-isam configure switch.
Portability fix for mysqlmanager. acconfig.h: Add HAVE_ISAM acinclude.m4: Add --without-isam configure switch. configure.in: Add --without-isam configure switch. include/my_global.h: remove #define HAVE_ISAM libmysqld/examples/test-run: pass --language option to embedded server sql/Makefile.am: use @isam_libs@ instead of hard-coded values tools/mysqlmanager.c: #include <signal.h> for portability
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index a11b1d0c252..aed231622f6 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -30,8 +30,7 @@ SUBDIRS = share
libexec_PROGRAMS = mysqld
noinst_PROGRAMS = gen_lex_hash
gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
-LDADD = ../isam/libnisam.a \
- ../merge/libmerge.a \
+LDADD = @isam_libs@ \
../myisam/libmyisam.a \
../myisammrg/libmyisammrg.a \
../heap/libheap.a \