summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <malff/marcsql@weblab.(none)>2006-08-17 16:08:51 -0700
committerunknown <malff/marcsql@weblab.(none)>2006-08-17 16:08:51 -0700
commitdec9116f4eec68cc15c4e543d1ad372762d20653 (patch)
tree9494137031e44102ca4470248d644c2d05c6f868 /sql/Makefile.am
parentb747f9732b008efc3dfefb4e0344cfa1b9e14e56 (diff)
downloadmariadb-git-dec9116f4eec68cc15c4e543d1ad372762d20653.tar.gz
WL#3432 (Compile the Parser with a --debug --verbose option)
Changed the automake build process : - ./configure.in - ./sql/Makefile.am to compile an instrumented parser for debug=yes or debug=full builds Changed the (primary) runtime invocation of the parser : - sql/sql_parse.cc to generate bison traces in stderr when the DBUG "parser_debug" flag is set. configure.in: WL#3432 (Compile the Parser with a --debug --verbose option) New Automake condition : MYSQL_CONF_DEBUG sql/Makefile.am: WL#3432 (Compile the Parser with a --debug --verbose option) In Debug mode, compile sql_yacc.yy with --debug --verbose sql/sql_parse.cc: WL#3432 (Compile the Parser with a --debug --verbose option) Conditionally turn the bison parser debug on at runtime.
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 8428d6401b5..251fbaa1c9a 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -117,9 +117,14 @@ DEFS = -DMYSQL_SERVER \
BUILT_SOURCES = sql_yacc.cc sql_yacc.h lex_hash.h
EXTRA_DIST = $(BUILT_SOURCES)
-DISTCLEANFILES = lex_hash.h
+DISTCLEANFILES = lex_hash.h sql_yacc.output
+
AM_YFLAGS = -d
+if MYSQL_CONF_DEBUG
+AM_YFLAGS += --debug --verbose
+endif
+
mysql_tzinfo_to_sql.cc:
rm -f mysql_tzinfo_to_sql.cc
@LN_CP_F@ $(srcdir)/tztime.cc mysql_tzinfo_to_sql.cc