summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorMikael Ronstrom <mikael@mysql.com>2009-03-06 16:13:11 +0100
committerMikael Ronstrom <mikael@mysql.com>2009-03-06 16:13:11 +0100
commitea9e898bed696ca2a984aa144d70be85da3e9710 (patch)
treebf5f60bc6140c97fc092fb09fc439dd2c051f316 /sql/Makefile.am
parentc494cbe42047f772d544013d6829b2ace9a7a0d4 (diff)
downloadmariadb-git-ea9e898bed696ca2a984aa144d70be85da3e9710.tar.gz
Fix for fix of the DTrace make problems
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index cca02ecc47a..9ffab8cba52 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -248,12 +248,12 @@ probes_all.o: probes_mysql.d $(DTRACEFILES_DEPEND)
# Can't depend directly on .libs/*.o, because there is no generated rule for
# that in the Makefile; it is a byproduct of *.lo
probes_libndb.o: probes_mysql.d libndb_la-ha_ndbcluster.lo
- if test -f .libs/libndb_la-ha_ndbcluster.o ; then
- $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d .libs/libndb_la-ha_ndbcluster.o -o $@
- endif
- if test -f libndb_la-ha_ndbcluster.o ; then
- $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d libndb_la-ha_ndbcluster.o -o $@
- endif
+ if test -f .libs/libndb_la-ha_ndbcluster.o ; then \
+ $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d .libs/libndb_la-ha_ndbcluster.o -o $@; \
+ fi; \
+ if test -f libndb_la-ha_ndbcluster.o ; then \
+ $(DTRACE) $(DTRACEFLAGS) -G -s probes_mysql.d libndb_la-ha_ndbcluster.o -o $@; \
+ fi
endif