summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.blaudden>2007-04-04 12:42:52 +0200
committerunknown <msvensson@pilot.blaudden>2007-04-04 12:42:52 +0200
commit3246ffded9cf97d45191c293aae4c06d5bf017ea (patch)
tree1e360494e41e0afd5a07c5399c376596e6880e1e /sql/Makefile.am
parent85613003c71ee9ce9f7520eeac000e82b65d5638 (diff)
downloadmariadb-git-3246ffded9cf97d45191c293aae4c06d5bf017ea.tar.gz
Bug#25337 Cannot build with OpenSSL support
- Cleanup Makefile.am, simplify how we build gen_lex_hash and mysql_tzinfo_to_sql sql/Makefile.am: Build mysql_tz_info_to_sql directly from tztime.cc Group all settings for mysql_tzinfo_to_sql and gen_lex_hash together
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am21
1 files changed, 7 insertions, 14 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index a84475f3295..801020c7e64 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -27,8 +27,7 @@ SUBDIRS = share
libexec_PROGRAMS = mysqld
EXTRA_PROGRAMS = gen_lex_hash
bin_PROGRAMS = mysql_tzinfo_to_sql
-gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
-SUPPORTING_LIBS = $(top_builddir)/vio/libvio.a \
+SUPPORTING_LIBS = $(top_builddir)/vio/libvio.a \
$(top_builddir)/mysys/libmysys.a \
$(top_builddir)/dbug/libdbug.a \
$(top_builddir)/regex/libregex.a \
@@ -69,6 +68,7 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
event_data_objects.h event_scheduler.h \
sql_partition.h partition_info.h partition_element.h \
contributors.h sql_servers.h
+
mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
item.cc item_sum.cc item_buff.cc item_func.cc \
item_cmpfunc.cc item_strfunc.cc item_timefunc.cc \
@@ -110,11 +110,11 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
sql_builtin.cc sql_tablespace.cc partition_info.cc \
sql_servers.cc
-
gen_lex_hash_SOURCES = gen_lex_hash.cc
-gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)
-mysql_tzinfo_to_sql_SOURCES = mysql_tzinfo_to_sql.cc
-mysql_tzinfo_to_sql_LDADD = @MYSQLD_EXTRA_LDFLAGS@ $(LDADD) $(CXXLDFLAGS)
+gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
+
+mysql_tzinfo_to_sql_SOURCES = tztime.cc
+mysql_tzinfo_to_sql_CXXFLAGS= -DTZINFO2SQL
DEFS = -DMYSQL_SERVER \
-DDEFAULT_MYSQL_HOME="\"$(MYSQLBASEdir)\"" \
@@ -133,11 +133,7 @@ DISTCLEANFILES = $(EXTRA_PROGRAMS)
MAINTAINERCLEANFILES = $(BUILT_MAINT_SRC)
AM_YFLAGS = -d --verbose
-mysql_tzinfo_to_sql.cc:
- rm -f mysql_tzinfo_to_sql.cc
- @LN_CP_F@ $(srcdir)/tztime.cc mysql_tzinfo_to_sql.cc
-
-link_sources: mysql_tzinfo_to_sql.cc
+link_sources:
rm -f mini_client_errors.c
@LN_CP_F@ $(top_srcdir)/libmysql/errmsg.c mini_client_errors.c
rm -f pack.c
@@ -149,9 +145,6 @@ link_sources: mysql_tzinfo_to_sql.cc
rm -f my_user.c
@LN_CP_F@ $(top_srcdir)/sql-common/my_user.c my_user.c
-mysql_tzinfo_to_sql.o: $(mysql_tzinfo_to_sql_SOURCES)
- $(CXXCOMPILE) -c $(INCLUDES) -DTZINFO2SQL $<
-
# This generates lex_hash.h
# NOTE Built sources should depend on their sources not the tool
# this avoid the rebuild of the built files in a source dist