summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorpatg@patrick-galbraiths-computer.local <>2004-12-11 12:03:51 -0800
committerpatg@patrick-galbraiths-computer.local <>2004-12-11 12:03:51 -0800
commit301c4932521ce4ca62425010e0facfa30e62bb95 (patch)
tree4cf0445976bf34d5ebafc238fcbd6a9049c51fc7 /sql/Makefile.am
parent7d1b9541fcbc5b2ab8168f8e9b9a7f7fab6309aa (diff)
downloadmariadb-git-301c4932521ce4ca62425010e0facfa30e62bb95.tar.gz
First commit to mysql-5.0 tree to include MySQL Federated Storage Handler. This includes both the source and header files, test (results, test, require), and modifications to server and handler base files, and autoconf modifications to properly build federated handler.
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 7d2eda1e222..46242f9a542 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -62,7 +62,8 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
sp_head.h sp_pcontext.h sp_rcontext.h sp.h sp_cache.h \
parse_file.h sql_view.h sql_trigger.h \
examples/ha_example.h examples/ha_archive.h \
- examples/ha_tina.h
+ examples/ha_tina.h \
+ ha_federated.h
mysqld_SOURCES = sql_lex.cc sql_handler.cc \
item.cc item_sum.cc item_buff.cc item_func.cc \
@@ -98,7 +99,9 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc \
sp_head.cc sp_pcontext.cc sp_rcontext.cc sp.cc \
sp_cache.cc parse_file.cc sql_trigger.cc \
examples/ha_example.cc examples/ha_archive.cc \
- examples/ha_tina.cc
+ examples/ha_tina.cc \
+ ha_federated.cc
+
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)
mysql_tzinfo_to_sql_SOURCES = mysql_tzinfo_to_sql.cc