summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@shellback.(none)>2006-09-18 21:55:56 +0200
committerunknown <msvensson@shellback.(none)>2006-09-18 21:55:56 +0200
commit9d04dee35f74236af2be5f5ee020a8e2105c86ef (patch)
treeb7f95dccb309f924e17baf2cd6474df8704e1861 /sql/Makefile.am
parent35af88b78fb8d0a2c3e5de4d43fd51dd8677b5d5 (diff)
parentfb63fdb9eec07e815bda7d94a4d9632ede9380db (diff)
downloadmariadb-git-9d04dee35f74236af2be5f5ee020a8e2105c86ef.tar.gz
Merge shellback.(none):/home/msvensson/mysql/bug19738/my51-bug19738
into shellback.(none):/home/msvensson/mysql/mysql-5.1-maint extra/Makefile.am: Auto merged sql/Makefile.am: Auto merged sql/share/errmsg.txt: Auto merged storage/innobase/Makefile.am: Auto merged storage/innobase/handler/ha_innodb.cc: Auto merged
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index e472e6ae8f0..a2f53c3c2da 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -156,7 +156,11 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
# the following three should eventually be moved out of this directory