summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authormsvensson@shellback.(none) <>2006-09-18 21:55:20 +0200
committermsvensson@shellback.(none) <>2006-09-18 21:55:20 +0200
commitd94fa536821b66729ee505f2f58e2c9ba6eb36b8 (patch)
tree60313d9815622fa27c82653744b256c96b565f68 /sql/Makefile.am
parent52fd031f325931a19a055d657b1bd481da8b10e8 (diff)
parentb50c843b2595b83fc55f1fe0452ba6fa9ba55d06 (diff)
downloadmariadb-git-d94fa536821b66729ee505f2f58e2c9ba6eb36b8.tar.gz
Merge shellback.(none):/home/msvensson/mysql/bug19738/my50-bug19738
into shellback.(none):/home/msvensson/mysql/mysql-5.0-maint
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 98c8fe784eb..a317715922d 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -152,7 +152,11 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
# For testing of udf_example.so