summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authormskold/marty@linux.site <>2007-04-24 15:11:22 +0200
committermskold/marty@linux.site <>2007-04-24 15:11:22 +0200
commitcabef956c24d2d1ff91f9b7f794e73652cfef780 (patch)
tree1b0aeb3810da954769837643337d6d533291a411 /sql/Makefile.am
parentcf8ef29ca047f433fe6a3a90562a5d2c3a6f240f (diff)
parentfb6b0708b1230d2c6ea6adbb13170ff9e430c2d4 (diff)
downloadmariadb-git-cabef956c24d2d1ff91f9b7f794e73652cfef780.tar.gz
Merge mskold@bk-internal.mysql.com:/home/bk/mysql-5.1-ndb
into mysql.com:/windows/Linux_space/MySQL/mysql-5.1-new-ndb
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index a04386611f8..08f5d7c7e78 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -48,9 +48,9 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
procedure.h sql_class.h sql_lex.h sql_list.h \
sql_map.h sql_string.h unireg.h \
sql_error.h field.h handler.h mysqld_suffix.h \
- ha_partition.h \
- ha_ndbcluster.h ha_ndbcluster_binlog.h \
- ha_ndbcluster_tables.h rpl_constants.h \
+ ha_ndbcluster.h ha_ndbcluster_cond.h \
+ ha_ndbcluster_binlog.h ha_ndbcluster_tables.h
+ ha_partition.h rpl_constants.h \
opt_range.h protocol.h rpl_tblmap.h rpl_utility.h \
log.h sql_show.h rpl_rli.h rpl_mi.h \
sql_select.h structs.h table.h sql_udf.h hash_filo.h \
@@ -92,8 +92,8 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc sql_partition.cc \
log_event_old.cc rpl_record_old.cc \
discover.cc time.cc opt_range.cc opt_sum.cc \
records.cc filesort.cc handler.cc \
- ha_partition.cc \
- ha_ndbcluster.cc ha_ndbcluster_binlog.cc \
+ ha_ndbcluster.cc ha_ndbcluster_cond.cc \
+ ha_ndbcluster_binlog.cc ha_partition.cc \
sql_db.cc sql_table.cc sql_rename.cc sql_crypt.cc \
sql_load.cc mf_iocache.cc field_conv.cc sql_show.cc \
sql_udf.cc sql_analyse.cc sql_analyse.h sql_cache.cc \
@@ -156,10 +156,13 @@ lex_hash.h: gen_lex_hash.cc lex.h
./gen_lex_hash$(EXEEXT) > $@-t
$(MV) $@-t $@
-# the following three should eventually be moved out of this directory
+# the following four should eventually be moved out of this directory
ha_ndbcluster.o:ha_ndbcluster.cc ha_ndbcluster.h
$(CXXCOMPILE) @ndbcluster_includes@ $(LM_CFLAGS) -c $<
+ha_ndbcluster_cond.o:ha_ndbcluster_cond.cc ha_ndbcluster_cond.h
+ $(CXXCOMPILE) @ndbcluster_includes@ $(LM_CFLAGS) -c $<
+
ha_ndbcluster_binlog.o:ha_ndbcluster_binlog.cc ha_ndbcluster_binlog.h
$(CXXCOMPILE) @ndbcluster_includes@ $(LM_CFLAGS) -c $<