summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <malff/marcsql@weblab.(none)>2007-06-29 13:52:43 -0600
committerunknown <malff/marcsql@weblab.(none)>2007-06-29 13:52:43 -0600
commit2dcdd0f637e94d7de023278a402b5e1c192c4774 (patch)
tree9abd6bfce597ef51d3747ff2d875de0ec113b28b /sql/Makefile.am
parentda08172ff737a828662ccb10c7a49f9518e13e7c (diff)
downloadmariadb-git-2dcdd0f637e94d7de023278a402b5e1c192c4774.tar.gz
Bug#29451 (Broken makefile dependencies with libndb.la)
In Automake, mysqld_LDADD = libndb.la only adds libndb to the link command for mysqld, but does not declare a dependency. Added libndb.la to mysqld_DEPENDENCIES This fix a build race condition that currently breaks make -J builds, and also enforce a re-link of mysqld when libndb.la changes. sql/Makefile.am: Fixed missing dependency
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index b77f2fb6cf6..36d066758bc 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -36,7 +36,7 @@ SUPPORTING_LIBS = $(top_builddir)/vio/libvio.a \
$(top_builddir)/dbug/libdbug.a \
$(top_builddir)/regex/libregex.a \
$(top_builddir)/strings/libmystrings.a
-mysqld_DEPENDENCIES= @mysql_plugin_libs@ $(SUPPORTING_LIBS)
+mysqld_DEPENDENCIES= @mysql_plugin_libs@ $(SUPPORTING_LIBS) libndb.la
LDADD = $(SUPPORTING_LIBS) @ZLIB_LIBS@ @NDB_SCI_LIBS@
mysqld_LDADD = libndb.la \
@MYSQLD_EXTRA_LDFLAGS@ \