summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <sasha@mysql.sashanet.com>2001-08-09 18:16:43 -0600
committerunknown <sasha@mysql.sashanet.com>2001-08-09 18:16:43 -0600
commit473bdc7893c97be6a76e7db980131053002f77e4 (patch)
tree9d06bd339f6bb64b768d1643ebf486cac78790a1 /sql/Makefile.am
parent88c80bb9996c7d5055beb3e6b47dfddbe48a4ac7 (diff)
downloadmariadb-git-473bdc7893c97be6a76e7db980131053002f77e4.tar.gz
mysqlbinlog->client
BitKeeper/etc/ignore: Added client/log_event.cc client/log_event.h client/mf_iocache.c client/mf_iocache.cc client/mysqlbinlog client/mysys_priv.h mysql.kdevprj to the ignore list Makefile.am: do symlink hack in the client directory ( originally needed to get log_event.cc for mysqlbinlog) client/mysqlbinlog.cc: fixes to make it compile in the client directory libmysql/Makefile.shared: link mysqlbinlog dependencies into libmysqlclient libmysql/libmysql.c: make simple_command and net_safe_read extern ( for mysqlbinlog) sql/log_event.cc: removed pthread dependency in mysqlbinlog sql/log_event.h: removed pthread dependency in mysqlbinlog
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 28484f09b3d..f1941e1e25c 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -27,7 +27,6 @@ INCLUDES = @MT_INCLUDES@ \
-I$(srcdir) -I../include -I.. -I.
WRAPLIBS= @WRAPLIBS@
SUBDIRS = share
-bin_PROGRAMS = mysqlbinlog
libexec_PROGRAMS = mysqld
noinst_PROGRAMS = gen_lex_hash
gen_lex_hash_LDFLAGS = @NOINST_LDFLAGS@
@@ -83,9 +82,6 @@ mysqld_SOURCES = sql_lex.cc \
md5.c stacktrace.c
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)
-mysqlbinlog_SOURCES = mysqlbinlog.cc mini_client.cc net_serv.cc \
- mini_client_errors.c violite.c password.c
-mysqlbinlog_LDADD = $(LDADD) $(CXXLDFLAGS) # $(mysqld_LDADD)
DEFS = -DMYSQL_SERVER \
-DDEFAULT_MYSQL_HOME="\"$(MYSQLBASEdir)\"" \