summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <mskold/marty@mysql.com/linux.site>2007-04-23 11:25:33 +0200
committerunknown <mskold/marty@mysql.com/linux.site>2007-04-23 11:25:33 +0200
commite93129cb81f40b1f03938ab79fc7c0cbe54225ad (patch)
tree79c4e200e03cfcc5324bdba09a5cb78482b663a5 /sql/Makefile.am
parentc5e3610c6074331e70e5e8f4a0d58c4ec99a5a6b (diff)
downloadmariadb-git-e93129cb81f40b1f03938ab79fc7c0cbe54225ad.tar.gz
Moved all code related to engine_condition_pushdown to a new class,
ha_ndbcluster_cond. Added new files: sql/ha_ndbcluster_cond.h sql/ha_ndbcluster_cond.cc sql/ha_ndbcluster_cond.cc: BitKeeper file /windows/Linux_space/MySQL/mysql-5.0-ndb/sql/ha_ndbcluster_cond.cc sql/ha_ndbcluster_cond.h: BitKeeper file /windows/Linux_space/MySQL/mysql-5.0-ndb/sql/ha_ndbcluster_cond.h sql/Makefile.am: Added compilation of new separate files for engine_condition_pushdown sql/ha_ndbcluster.cc: Moved all code related to engine_condition_pushdown to ha_ndbcluster_cond sql/ha_ndbcluster.h: Moved all code related to engine_condition_pushdown to ha_ndbcluster_cond
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 4f84023724f..9be3bf93746 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -54,7 +54,8 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
sql_error.h field.h handler.h mysqld_suffix.h \
ha_myisammrg.h\
ha_heap.h ha_myisam.h ha_berkeley.h ha_innodb.h \
- ha_ndbcluster.h opt_range.h protocol.h \
+ ha_ndbcluster.h ha_ndbcluster_cond.h \
+ opt_range.h protocol.h \
sql_select.h structs.h table.h sql_udf.h hash_filo.h\
lex.h lex_symbol.h sql_acl.h sql_crypt.h \
log_event.h sql_repl.h slave.h \
@@ -88,7 +89,7 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc \
records.cc filesort.cc handler.cc \
ha_heap.cc ha_myisam.cc ha_myisammrg.cc \
ha_berkeley.cc ha_innodb.cc \
- ha_ndbcluster.cc \
+ ha_ndbcluster.cc ha_ndbcluster_cond.cc \
sql_db.cc sql_table.cc sql_rename.cc sql_crypt.cc \
sql_load.cc mf_iocache.cc field_conv.cc sql_show.cc \
sql_udf.cc sql_analyse.cc sql_analyse.h sql_cache.cc \