summaryrefslogtreecommitdiff
path: root/sql/share/Makefile.am
diff options
context:
space:
mode:
authorunknown <jimw@mysql.com>2005-08-23 11:25:24 -0700
committerunknown <jimw@mysql.com>2005-08-23 11:25:24 -0700
commit4b9431369611b4c3938288c0ef9eaa282f1bb417 (patch)
tree8f25e99f65e13c5974f8f6c711c8e7e6a78520a7 /sql/share/Makefile.am
parent4eccc160525552fd2421f5dc4b33afb320f2d52b (diff)
downloadmariadb-git-4b9431369611b4c3938288c0ef9eaa282f1bb417.tar.gz
Fix build using --without-server. (Bug #11680)
configure.in: Fix directories built using --without-server, and add mf_keycache.o to list of objects only built for thread-safe library, since it requires threading. dbug/my_main.c: Don't try to initialize thread globals if not built with threading. mysys/Makefile.am: Remove mf_keycache.c from list of files to build (it will be included in THREAD_LOBJECTS when appropriate). mysys/mf_getdate.c: Fix usage of gmtime(). sql/share/Makefile.am: Allow removal of mysqld_error.h to fail, in case it doesn't exist yet. tests/Makefile.am: Don't link against libmysys explicitly.
Diffstat (limited to 'sql/share/Makefile.am')
-rw-r--r--sql/share/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/sql/share/Makefile.am b/sql/share/Makefile.am
index b7ab8fead22..2e23027f1f5 100644
--- a/sql/share/Makefile.am
+++ b/sql/share/Makefile.am
@@ -33,7 +33,7 @@ all-local: english/errmsg.sys
# created. Normally these are created by extra/Makefile
english/errmsg.sys: errmsg.txt
- rm $(top_builddir)/include/mysqld_error.h
+ rm -f $(top_builddir)/include/mysqld_error.h
(cd $(top_builddir)/extra && $(MAKE))
install-data-local: