summaryrefslogtreecommitdiff
path: root/sql/share/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.com>2000-09-22 01:46:26 +0300
committerunknown <monty@donna.mysql.com>2000-09-22 01:46:26 +0300
commit5f12486229fb578f2e170238ab2cdd7c9bf42a82 (patch)
tree578e79cb989b0a5458b2f7b7cd27600813a79432 /sql/share/Makefile.am
parent5e955288bc695e2f7a92c5549c7753309b41bed7 (diff)
downloadmariadb-git-5f12486229fb578f2e170238ab2cdd7c9bf42a82.tar.gz
Fixes for MyISAM and packed keys + AIX
Docs/manual.texi: Updated changelog client/mysql.cc: Free all memory, even if we can't connect to the server include/config-win.h: Ensure that we don't use SAFE_MUTEX on windows include/my_pthread.h: Optimze struct for Ia64 include/myisam.h: Hack for debugging BIG tables myisam/mi_check.c: Hack for debugging BIG tables myisam/mi_search.c: Fixed bug in packed keys myisam/myisamchk.c: Hack for debugging BIG tables mysys/thr_mutex.c: Make safe_mutex safe for windows scripts/safe_mysqld.sh: Fix nice test and echo output sql/share/Makefile.am: Fix character sets sql/sql_string.cc: Fixes for AIX (which can't handle that the length argument is 0)
Diffstat (limited to 'sql/share/Makefile.am')
-rw-r--r--sql/share/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/sql/share/Makefile.am b/sql/share/Makefile.am
index 6080899c33e..cee8d4e2d0b 100644
--- a/sql/share/Makefile.am
+++ b/sql/share/Makefile.am
@@ -16,7 +16,8 @@ install-data-local:
$(DESTDIR)$(pkgdatadir)/$$lang/errmsg.txt; \
done
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/charsets
- (cd $(srcdir)/charsets; for f in Index README "*.conf"; \
+ (for f in $(srcdir)/charsets/Index $(srcdir)/charsets/README $(srcdir)/charsets/*.conf; \
do \
- $(INSTALL_DATA) $$f $(DESTDIR)$(pkgdatadir)/charsets/; \
+ n=`basename $$f`; \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgdatadir)/charsets/$$n; \
done)