summaryrefslogtreecommitdiff
path: root/sql/share/Makefile.am
diff options
context:
space:
mode:
authorunknown <serg@hynda.mysql.fi>2001-01-14 12:56:44 +0200
committerunknown <serg@hynda.mysql.fi>2001-01-14 12:56:44 +0200
commitecdc9ee9984b833c146b63affeb8de5b972e00fd (patch)
treecf6178d1ba10b88ce084fa89e730d96aba974c83 /sql/share/Makefile.am
parenta4de78dc3bd4fea83f699028aa30462daa0a034d (diff)
downloadmariadb-git-ecdc9ee9984b833c146b63affeb8de5b972e00fd.tar.gz
Makefile.am rules for */errmsg.sys refined
sql/share/Makefile.am: rules for */errmsg.sys refined BitKeeper/etc/logging_ok: Logging to logging@openlogging.org accepted
Diffstat (limited to 'sql/share/Makefile.am')
-rw-r--r--sql/share/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/sql/share/Makefile.am b/sql/share/Makefile.am
index afdcdd8f81c..e662c4f09a2 100644
--- a/sql/share/Makefile.am
+++ b/sql/share/Makefile.am
@@ -1,15 +1,16 @@
## Process this file with automake to create Makefile.in
+ERRMSG=$(patsubst %, %/errmsg.sys, @AVAILABLE_LANGUAGES@)
+
# This requires gnu cp at distribution time.
dist-hook:
for lang in @AVAILABLE_LANGUAGES@ charsets; \
do cp -a $(srcdir)/$$lang $(distdir); done
-all:
- for lang in @AVAILABLE_LANGUAGES@; \
- do \
- ../../extra/comp_err $(srcdir)/$$lang/errmsg.txt $(srcdir)/$$lang/errmsg.sys; \
- done
+all: $(ERRMSG)
+
+$(ERRMSG): %.sys: %.txt
+ ../../extra/comp_err $< $@
install-data-local:
for lang in @AVAILABLE_LANGUAGES@; \